a reliable sign that it’s time to upgrade Flex frameworks

If you’ve seen errors that look like this when building large and complex projects:

[compc] _SomeClass_mx_core_FlexModuleFactory.as(15): col: 14 Error: Interface method get preloadedRSLs in namespace mx.core:IFlexModuleFactory not implemented by class _SomeClass_mx_core_FlexModuleFactory.

or maybe this:


[compc] _SomeClass_mx_core_FlexModuleFactory.as(15): col: 14 Error: Interface method allowDomain in namespace mx.core:IFlexModuleFactory not implemented by class _SomeClass_mx_core_FlexModuleFactory.

It’s time to upgrade or downgrade your SDK to match what everyone else is using because somewhere, somehow, your SDKs are colliding unhappily. Probably you’ll need to update from something like 3.3 to 3.4 or 3.5.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>